Some Emoticons are not properly rendering in MultiExcerpt on New (Fabric/V2) Editor Pages

Problem

For Multiexcerpt - Cloud: Some of the Emoticons are not rendering properly when placed inside a MultiExcerpt

This happens only in the new fabric(V2) page editor. It works for the old editor. This is only an issue in Confluence Cloud.  It only happens for the dynamic (Fast) MultiExcerpt and MultiExcerpt Include macros.  It does not happen for the static macros.

Emoticons that were available in old/legacy pages work fine in the new/fabric page editor:

(smile)                    

Emoticons that are new in the new/fabric page editor are broken


Why it Happens

Confluence incorrectly styles "new" emoticons as "emoticon-blue-star" when they are rendered in the body of a third party macro (if the macro is a "rich-text staticContentMacro").

THIS IS A BUG IN CONFLUENCE:  CONFCLOUD-69848

We recommend that you open a support case directly with Atlassian requesting that the source of emoji values be available to third-party rich-text macros.  Please give your feedback to Atlassian about their decision to provide this information to macros by voting on or commenting on CONFCLOUD-69848 


Workaround

If you use the new/fabric page editor then use the DYNAMIC (Fast) MultiExcerpt macros instead of the STATIC ones. The “Fast” MultiExcerpt macros are the dynamic ones.  See MultiExcerpt Cloud - User Guide#UserGuide-DifferenceBetweenMultiexcerptandMultiexcerptFast

Same thing goes for MultiExcerpt Includes. Use the DYNAMIC (Fast) ones instead of the STATIC ones. Emoticons that are available in the new/fabric page editor but not available in the old/legacy editor are the ones that are broken.

OR... use the old/legacy page editor.  Atlassian has announced that they will NOT remove the legacy page editor from Confluence so you can use that editor: Atlassian says, "The legacy editor isn't going anywhere"  

If your site does not have the legacy page editor template available when creating pages then you can open a support case with Atlassian to have them turn it on for your site.

We recommend that you open a support case directly with Atlassian requesting that the source of emoji values be available to third-party rich-text macros.  Please give your feedback to Atlassian about this bug by voting on or commenting on CONFCLOUD-69848 

We are keeping track of our internal efforts by using Issue  MEPOD-93 - Getting issue details... STATUS